Uninstalling Avi Load Balancer in VMware Cloud Foundation 9.1 fails with the error "service user delete failed".
The following error message is displayed:
"Avi Load Balancer #### service user delete failed."
The following output is recorded in the SDDC Manager's `domainmanager.log`:
YYYY-MM-DDTHH:MM:SS ERROR [vcf_dm,###,###] [c.v.v.s.https.vapi.VapiClientFactory,dm-exec-###] Unable to create a session for [email protected] on VC_FQDNjava.util.concurrent.ExecutionException: com.vmware.vapi.std.errors.Unauthenticated: Unauthenticated (com.vmware.vapi.std.errors.unauthenticated) => { messages = [], data = <null>, errorType = UNAUTHENTICATED, challenge = SIGN realm="###",sts="https://VC_FQDN/sts/STSService/vsphere.local", Basic realm="vCenter"}
VMware Cloud Foundation 9.1
If the password for [email protected] differs between SDDC Manager and vCenter Server, authentication from SDDC Manager to vCenter Server using [email protected] fails. Consequently, the user deletion process on vCenter Server cannot be performed, causing the Avi Load Balancer uninstallation to fail.
Use "lookup_passwords" to check the password for "[email protected]" on the SDDC Manager side, and verify that you cannot log in to vCenter Server using that password.
Use the SDDC Manager Appliance to Look Up Account Credentials
Update the password for [email protected] on SDDC Manager to match the password used on vCenter Server.
After modifying the password on the SDDC Manager side, run the Avi Load Balancer uninstallation task again.